Cloudflare Outage Impacting Blackthorn Events

Incident Report for Blackthorn

Resolved

This incident has been resolved. We are continuing to monitor the situation, but please contact Blackthorn Support at https://community.blackthorn.io/s/support if you experience any further issues.
Posted Jun 12, 2025 - 22:44 UTC

Monitoring

Cloudflare services have been restored and are now fully operational. We are monitoring the situation, but please contact Blackthorn Support at https://community.blackthorn.io/s/support if you run into any issues going forward.

To stay updated on Cloudflare’s real-time status, visit:
https://www.cloudflarestatus.com/

Thank you!
Posted Jun 12, 2025 - 21:33 UTC

Investigating

We are currently experiencing issues due to a significant Cloudflare outage, which affects the service we use to power vanity domains and manage traffic routing across regions.

Our team is actively working to monitor the situation and restore full app stability. We’ll provide updates as soon as we have more information.

In the meantime, you can access your events using the default Blackthorn URL format:
https://events.blackthorn.io/sample-event

Instead of:
https://events.yourdomain.com/sample-event

Documentation:
https://docs.blackthorn.io/docs/events-admin-tab-settings

To stay updated on Cloudflare’s real-time status, visit:
https://www.cloudflarestatus.com/

For broader context on this major Cloudflare outage, you can also refer to:
https://nypost.com/2025/06/12/business/google-cloud-users-report-widespread-outages-across-us/

Thank you for your patience and understanding.
Posted Jun 12, 2025 - 19:03 UTC
This incident affected: Blackthorn Events.